viernes, 18 de diciembre de 2009

Cálculos a Partir de un Valor Mínimo



"Necesito realizar el promedio de una serie de números que se encuentran en una tabla pero quiero realizar el promedio de aquellos que superan un valor mínimo".

Para resolver este problema vamos a utilizar las funciones PROMEDIO y SI en Fórmula Matricial. Partimos del siguiente ejemplo:


En C2 hemos establecido un valor mínimo y queremos calcular el promedio de cada una de las clases pero sólo de aquellos valores que superen dicho mínimo.

Nos situamos en la celda B22 y escribimos la siguiente FÓRMULA MATRICIAL (lo que implica que al terminar de escribir la fórmula, en vez de pulsar Enter debemos pulsar la combinación de teclas Ctrl + Shift + Enter):

{=PROMEDIO(SI(B$5:B$20>=$C$2;B$5:B$20))}

De esta manera excel calcula el promedio de aquellos valores del rango B5:B20 que superen o sean iguales al valor indicado en C2. Puede copiar la fórmula de B22 en C22 y D22 para calcular el promedio de cada clase.

Esta misma fórmula la podríamos adaptar para realizar el cálculo de la SUMA, CONTAR o, por ejemplo, calcular el MINIMO desde un valor:

En B24 {=SUMA(SI(B$5:B$20>=$C$2;B$5:B$20))}

En B25 {=CONTAR(SI(B$5:B$20>=$C$2;B$5:B$20))}

En B26 {=MIN(SI(B$5:B$20>=$C$2;B$5:B$20))}


No hay comentarios:

Publicar un comentario en la entrada