sábado, 16 de octubre de 2010

Cálculo de la Frecuencia de la Moda


"En un post de tu blog , explicas cómo hallar el valor más repetido en un rango (la moda). Lo que yo necesito es, además de saber dicho valor, saber cuántas veces se repite".

El post al que te refieres es Cálculo del Valor más Frecuente (MODA) de un Rango. Para dar solución a tu pregunta utilizaremos las funciones CONTAR.SI y MODA. Partimos del siguiente ejemplo que muestra las valoraciones obtenidas en las encuestas realizadas a cuatro tiendas:


Nos situamos en la celda B17 y escribimos la siguiente fórmula:

=CONTAR.SI(B4:B15;MODA(B4:B15))

De esta manera lo que estamos haciendo es utilizar como criterio para contar el valor de la moda, es decir, que cuente cuántas veces se repite el valor de la moda en el rango B4:B15 . En nuestro ejemplo sólo nos quedaría copiar la fórmula introducida en B17 en el rango C17:E17 .

Si además queremos tener disponible el valor en si de la Moda podemos escribir en B19 la fórmula:

=MODA(B4:B15) y copiar esta fórmula en el rango C19:E19


Como se puede comprobar, el valor de la Moda de las encuestas de la Tienda 1 es 2 y dicho valor se repite 4 veces.

No hay comentarios:

Publicar un comentario en la entrada