lunes, 9 de noviembre de 2015

Aleatorios Acotados con Promedio Objetivo


"Necesito generar números aleatorios entre valores determinados (por ejemplo, valores no inferiores a 498 y no superiores a 504) cuyo promedio sea un número concreto que se encuentre entre ambos límites (por ejemplo 500)".

Es un caso muy similar al resuelto en mi post Generar Aleatorios que Sumen una Cifra Objetiva, pero con algún ajuste que paso a comentar. Partimos del siguiente ejemplo y entrada de datos:
En la celda E7 escribimos la siguiente fórmula, que nos generará números aleatorios comprendidos entre los valores especificados en las celdas C4 y C5:
=ALEATORIO()*($C$4-$C$5)+$C$5  y copiamos hasta E21:
En la celda C7 escribimos la siguiente fórmula:
=((E7/SUMA($E$7:$E$21))*$C$2)*$C$3  y la copiamos hasta C21:
Podemos pulsar la tecla F9 para generar nuevos valores aleatorios y comprobar que la celda C23, que contiene la fórmula =PROMEDIO(C7:C21), mantiene el mismo valor que el objetivo indicado en la celda C2.

No hay comentarios:

Publicar un comentario en la entrada