jueves, 11 de junio de 2009

Cálculos Simultáneos en una Celda



Hoy vamos a ver cómo se pueden realizar cálculos simultáneos en una única celda. Supongamos que tenemos los ingresos y gastos de diversas áreas de un negocio y queremos calcular el margen y el porcentaje que representa dicho margen sobre los ingresos. Pero queremos que muestre ambos resultados (el margen en Euros y el porcentaje sobre ingresos) en la misma celda.


Partiendo del ejemplo mostrado en la imagen, queremos realizar en E4 los cálculos citados. Para ello necesitaremos utilizar la función CONCATENAR o, lo que es lo mismo pero más corto, &. Nos situamos en E4 y escribimos la siguiente fórmula:
=C4-D4&" "&(C4-D4)/C4

C4-D4 calcula el margen en euros
&" " une al resultado calculado tres espacios en blanco (para separar del siguiente cálculo)
&(C4-D4)/C4 une a todo lo anterior el cálculo del porcentaje que supone el margen sobre el ingreso.

El resultado de esta fórmula será:


Aunque el resultado numérico es correcto, creo que estará de acuerdo conmigo en que el formato presentado no es el más conveniente... Cuando realicemos cálculos y utilicemos la función CONCATENAR nos encontraremos con este problema de formatos. Para solucionarlo podemos acudir a la función TEXTO.

TEXTO(Valor;Formato)
Esta función convierte un valor en texto con un formato determinado. El argumento Valor es un valor numérico o una fórmula que nos proporciona un valor numérico. El argumento Formato es el formato que queremos darle al Valor en cuestión. El formato elegido debemos introducirlo entre comillas y podemos indicar cualquiera de las posibilidades que se pueden encontrar en el menú Formato/Celdas/Numero.

Nos situamos nuevamente en E4 y procedemos a aplicar esta función a nuestra fórmula inicial:
=TEXTO(C4-D4;"0.00€")&" "&TEXTO((C4-D4)/C4;"0,00%")

Fíjese que hemos añadido la función TEXTO para conseguir que el primer cálculo aparezca con formato de moneda (0.00€) y el segundo cálculo con formato porcentual (0,00%). Una vez hecha esta fórmula y copiada en el rango E5:E11 el resultado será:


Si queremos añadir el margen total y el porcentaje sobre los ingresos totales deberemos realizar una nueva fórmula en E12. A saber:
=TEXTO(SUMA(C4:C11)-SUMA(D4:D11);"0.00€")&" "&TEXTO((C12-D12)/C12;"0,00%")


No hay comentarios:

Publicar un comentario en la entrada