miércoles, 19 de febrero de 2014

Promedio de Valores Intermedios

"Necesito hacer un promedio de cifras relativas a 11 años, de los cuales debo eliminar los dos de valor superior y los dos de valor inferior, sean estos iguales o no".

Vamos a solucionar este problema utilizando las funciones INDICE, K.ESIMO.MAYOR y PROMEDIO. Partimos del siguiente ejemplo:
Lo primero que hacemos es crear una tabla como la que se muestra a continuación en la que en la primera fila escribiremos números de orden, en nuestro ejemplo 11. En la celda G4 escribimos la fórmula:
=K.ESIMO.MAYOR(B$4:B$14;$F4)
Con esta fórmula, que debemos copiar hasta I4 y finalmente hasta I14, ordenaremos de mayor a menor por columna los valores:
Una vez hecho esto los valores que nos interesan son los sombreados en verde, es decir, los 7 valores intermedios. Para calcular el promedio de estos valores utilizamos la fórmula siguiente que escribiremos en la celda B17 (y posteriormente copiamos hasta D17):
=PROMEDIO(INDICE(G$4:G$14;3):INDICE(G$4:G$14;9))

No hay comentarios:

Publicar un comentario en la entrada